Sharepoint Forums 1.2.0.0: That assembly does not allow partially trusted callers

Topics: Bug Hunt, Developer Forum, Project Management Forum, User Forum
Feb 14, 2008 at 2:06 PM
Hi All,

I have recently downloaded the SharePoint Forums Web Part and installed it on my WSS 3.0 SP1 server. The install goes through fine but when I try to add the web part it gives me the following error message.

"Sharepoint Forums 1.2.0.0: That assembly does not allow partially trusted callers"

What does this mean and how can I fix it?

Regards,

Ruaan
Mar 25, 2009 at 3:22 PM
I am also receiving this error after following these steps outlined in the WSS 3.0 installation discussion:
http://spforums.codeplex.com/Thread/View.aspx?ThreadId=49770

Any suggestions?

Do I need to redeploy to the GAC (Global Assembly Cache).  Don't see that as best practice, but that was first thought that jumped to mind...


Mar 25, 2009 at 4:00 PM
Disregard my problem - I was able to get the web part added.

I was doing several iterations of the install, and I ended up using Central Administration > Solution Management GUI rather than the command line to deploy the solution.

Bill - you had outlined to use this command in those instructions:
stsadm.exe -o addwppack -filename "SharePointForums-1.2.0.0_Bil Simser.cab" -globalinstall -force

I did that to redeploy, and was good to go.

That said, I think this solution is being added to the GAC, and not the Web Application bin only, correct?  Can someone explain to me why that is?