can't find .snk file in source code

Topics: Bug Hunt, Developer Forum, Project Management Forum, User Forum
Nov 21, 2008 at 1:48 PM
Hi Bill,
firstly love the webpart, look so much better than  the MOSS 2007 one. I have been hunting round the net and the discussions here and one of the fixes for the subit button not working in MOSS2007 requires that i recompile the code. I can;t however find the .snk file in any of the downloads or vis SVN. Am I being thick or is it missing ???


Many Thanks

Chris
Apr 15, 2009 at 1:23 PM
Hello,

I have the same issue with the snk file.
Did you find the solution?

My errors :
-Erreur 388 
Encryption failded while assembly signing 'C:...\SharePointForums-1.2.0.0-Source\src\obj\Debug\BilSimser.SharePoint.WebParts.Forums.dll'
SharePointForums.WebPart.snk is unfound

-Erreur 1070
the metadata file 'C:...\SharePointForums-1.2.0.0-Source\src\bin\Debug\BilSimser.SharePoint.WebParts.Forums.dll' is unfound.
Project : SharePointForums.UnitTests

Thanks by advance,

noche
Jul 3, 2009 at 10:55 AM

holla!!!!  

i'm also getting same.. any help wud be greatly appreciated

Coordinator
Jul 20, 2009 at 8:18 PM

You can create a new .snk file inside of Visual Studio and sign the assembly with it. I'm not sure if the old codebase has it in it (it might be there but not linked). The last few changesets with the 2007 version has it in there.

Dec 4, 2009 at 7:59 AM
Edited Dec 4, 2009 at 8:22 AM

I was having the same problem!

for some reason when i wanted to build the solution, it stated could not find file solution.snk

I noticed in the error message it had spell the name wrong for the .snk file (Im not sure exactly why).  All I did is rename the .snk file to what it said in the error message and it build the solution successfully.