Analytics Not working after windows and SharePoint Security updates installed in SharePoint 2013

Topics: Bug Hunt, User Forum
Feb 25 at 3:25 PM
I was installed windows updates and SharePoint Security updates in SharePoint 2013, next day on words Analytics not working, Everything working as expected but no metrics in the Popularity trends and most Popular Items, Showing Zero results.

"EventStore" in the MicroSoft Office servers is empty after Windows updates.

1) All the related Timer jobs are running,

2) "Analytics" and "Page Request" receivers are enabled,

Tried below Script Also:

Add-PSSnapin Microsoft.SharePoint.PowerShell $aud = Get-SPUsageDefinition | where {$_.Name -like "Analytics*"}

if($aud.Receivers.Count -eq 0) { $aud.Receivers.Add("Microsoft.Office.Server.Search.Applications, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c", "Microsoft.Office.Server.Search.Analytics.Internal.AnalyticsCustomRequestUsageReceiver") }

if($aud.EnableReceivers -eq $false) { $aud.EnableReceivers = $true $aud.Update() } $aud | fl $prud = Get-SPUsageDefinition | where {$_.Name -like "Page Requests"}

if($prud.Receivers.Count -eq 0) { $prud.Receivers.Add("Microsoft.Office.Server.Search.Applications, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c", "Microsoft.Office.Server.Search.Analytics.Internal.ViewRequestUsageReceiver")
}

if page requests usage definition receiver is not enabled then enable it

if($prud.EnableReceivers -eq $false) { $prud.EnableReceivers = $true $prud.Update() } $prud | fl 3) In the "Get-SPUsageDefinition" everything is fine.

4) Restarted the Timer Services.

5) ImportProgress.ini file configured correctly.

6) Did Search Index reset, and Continues is crawl running.

7) Cleared all log files and reconfigured.

How can I resolve this issue?