Current Known Problems

This is a list of known problems with the Web Part and any workarounds or fixes. Also links to work items that are assigned to the problem will be listed here.
  • Saving properties on SPS
    • The system uses Web Part properties to save information (like the forum name) and retrieve these later. When the web part is placed on a SPS area, saving produces an error saying "Access Denied saving Web Part properties..." (even if you have admin rights). This is being investigated for a future fix.
  • Security errors when installing (v1.0 only)
    • This is probably the most common problem and happens to most people. A few things to watch out for:
      • Use a domain (not SYSTEM or NETWORK_SERVICE) for the Application Pool account.
      • Do not enable anonymous users on the system (it currently does not support it)
      • Ensure the SafeControl entries are added to the proper web.config file
  • Deploying on SPS areas (v1.1)
    • There is a problem (related to saving properties in SPS installations) that is causing the use of the web part on SPS areas to be problematic. Several properties are now saved back to the web part and unfortunately they're not working correctly on SPS setups. The workaround is to create a WSS site or Web Part Page in a WSS site to host it and expose this (through a the Page Viewer Web Part) on your portal. As with the above issue, we are looking at what the problem is saving properties on SPS and will correct it as soon as possible.
  • Uninstalling Web Part does not remove hidden lists
    • If you uninstall the Web Part through the Add/Remove Programs list (v1.1 only) or remove it from a Web Part Page, it does not remove the lists. There are several hidden lists the Web Part uses (and recreates if missing) and these lists are not removed. Unfortunately it's nearly impossible to detect when someone removes the Web Part from a page so we cannot remove the lists automatically. You will have to remove them manually using FrontPage, SharePoint Explorer, or another tool.

Last edited Jul 5, 2006 at 4:25 AM by bsimser, version 5

Comments

saber13812002 Oct 15, 2008 at 6:51 AM 
Now, on the production SPS portal, I'm getting a failure when i add web part to page.
after i add web part to web parts entries.
...
i added the safecontrol entries in web.config files that related to my site in MOSS
but show me this error : is not safe web part.
help me

ncjks Aug 10, 2006 at 8:50 PM 
I've installed on WSS three times with no problem. Now, on the production SPS portal, I'm getting a failure on install that says it could not find the virtual server specified.

I've tried my computer name, "localhost" my DNS name, my IP address all with and without port numbers and all with and without HTTPs.

I tried all virtual servers

It always returns "Can not find the virtual server specified."

Any clues?

JK