Installing the Web Part (version 1.1)

These are the installation instructions for version 1.1 of the SharePoint Forums Web Part. As of version 1.1 there is now an MSI package that will do the installation for you.

NOTE: Version 1.1 is currently a GAC only install, that is, you cannot install it to the BIN directory like the previous version (well, you could but you'll need to a lot of manual effort to make it work). At this point this is the simplest installation available. For those that are feeling icky about a GAC install there will be an update so you can install both (with a new custom policy file).
  • Step 1
    • Download the SharePointForums- from the Releases tab here.
  • Step 2
    • Run the MSI on your SharePoint server. You may choose to install it on all virtual servers or just specify a single one.
  • Step 3
    • When prompted to install the assemblies to the GAC, choose Yes.
  • Step 4
    • Reset Internet Information Services (IIS) on the SharePoint server. Alternately, you can recycle the Application Pool.
  • Step 5
    • Browse to a WSS site and click on Modify Shared Page. Click on Add Web Parts then Browse. Select the Virtual Server Gallery and locate the SharePoint Forums Web Part from the gallery. Add it to your page.
  • Step 6
    • Configure and have fun!

Last edited Jul 5, 2006 at 3:46 PM by bsimser, version 5


yahoolian Feb 18, 2010 at 1:28 PM 
To install on Sharepoint 3.0 and to fix the Post button not working issue, try downloading my patched version instead:

After download, open a command window and
to the folder of the cab file. then

stsadm -o deletewppack -name ""
stsadm -o addwppack -filename "" -globalinstall -force -url "http://my_sharepoint_site/"
stsadm -o addwppack -filename "" -globalinstall -force -url "http://my_sharepoint_site/"

Also might need to restart IIS.

joeainsworth Dec 1, 2008 at 7:27 PM 
I am having the same issue with this web part. I did what yahoolian said, and now the forum can be placed on the site, but I get the same as KiloMike when I try to create a post. Any ideas?

KiloMike Oct 22, 2008 at 6:09 PM 

thanks for the quick guide for wss3. did it well, but my problem now is when I try to create a new post/topic I get the form to fill out subject and message but after clicking on "Post" nothing happens. Under firefox the my message is HTML-formated (the HTML tags are added), under IE nothing happens. Any suggestions what may cause it??

pvenkat07rd003 Jun 10, 2008 at 10:10 AM 
I don't get any dialog box. But it is appearing in the Add/Remove Programes. If I try to install once again getting some message like u already installed...........
Any Help Please. Thanks

MrTim May 1, 2008 at 12:38 PM 
Yes, me too. Install starts and that's it. I can see SharePoint Forums in Add/Remove but no additional web parts are installed and no dialogs popped up. And I too got a fatal error.

jalvey May 2, 2007 at 7:03 PM 
I am unable to get this to install. I run the MSI but no dialogs ever appear. (I have tried installing 1.1 and 1.2) When I try to repair it under the add remove programs it says there is a fatal error. Any ideas?